Bundles

bluetoother

stmu - the utilities bundle

Latest version: 20201125

Projects included in the bundle


Snap package

No snap available at the moment for this bundle.


Debian binary packages (amd64 architecture)

For Debian based Linux distros like Debian, Ubuntu, Linux Mint, etc.

Hardware: PCs (x86-64 or amd64 CPUs)

Note: the sudo package must be installed and your user must have permission to execute commands as superuser.

Prerequisite packages

$ sudo apt-get install libgtkmm-3.0-1v5 libbluetooth3 bluez sox espeak policykit-1

Download, unzip and install

$ wget https://www.efanomars.com/bins/stmu-20201125-deb-amd64-d09.tar.gz
$ sha256sum stmu-20201125-deb-amd64-d09.tar.gz    # should return
$ # a73f00fabe3002f71e35589804375ccf32cf08ac205c4e378c20c5a2aed7e2cb
$ tar xvz -f stmu-20201125-deb-amd64-d09.tar.gz
$ cd stmu-20201125-deb-amd64
$ ./install-all.sh

Run

$ sonorem
$ pkexec bluetoother # or sudo bluetoother

Uninstall

From the same directory of install-all.sh
$ ./uninstall-all.sh


Arch binary packages (amd64 architecture)

For Arch Linux based distros like Arch, Manjaro, etc.

Hardware: PCs (x86-64 or amd64 CPUs)

Note: the sudo package must be installed and your user must have permission to execute commands as superuser.

Prerequisite packages

$ sudo pacman -S gtkmm3 bluez bluez-libs sox espeak polkit

Download, unzip and install

$ wget https://www.efanomars.com/bins/stmu-20201125-arch-amd64-m.tar.gz
$ sha256sum stmu-20201125-arch-amd64-m.tar.gz    # should return
$ # be3f1482655a5cb48c0f15bab723969e9c66a9eaa59ec01820324ff082d9257c
$ tar xvz -f stmu-20201125-arch-amd64-m.tar.gz
$ cd stmu-20201125-arch-amd64
$ ./install-all.sh

Run

$ sonorem
$ pkexec bluetoother # or sudo bluetoother

Uninstall

From the same directory of install-all.sh
$ ./uninstall-all.sh


Debian binary packages (arm64 architecture)

For Debian based Linux distros like Raspberry Pi OS, Debian, Ubuntu, etc.

Hardware: Raspberry Pi 4, PineBook

Note: the sudo package must be installed and your user must have permission to execute commands as superuser.

Prerequisite packages

$ sudo apt-get install libgtkmm-3.0-1v5 libbluetooth3 bluez sox espeak policykit-1

Download, unzip and install

$ wget https://www.efanomars.com/bins/stmu-20201125-deb-arm64-d09.tar.gz
$ sha256sum stmu-20201125-deb-arm64-d09.tar.gz    # should return
$ # f3bd9edebd90c5c1101c2691f3ce69c88acad32b22f489c57285dcdcd7912e96
$ tar xvz -f stmu-20201125-deb-arm64-d09.tar.gz
$ cd stmu-20201125-deb-arm64
$ ./install-all.sh

Run

$ sonorem
$ pkexec bluetoother # or sudo bluetoother

Uninstall

From the same directory of install-all.sh
$ ./uninstall-all.sh


Arch binary packages (arm64 architecture)

For Arch Linux based distros like Arch, Manjaro, etc.

Hardware: PineBook, Raspberry Pi 4

Note: the sudo package must be installed and your user must have permission to execute commands as superuser.

Prerequisite packages

$ sudo pacman -S gtkmm3 bluez bluez-libs sox espeak polkit

Download, unzip and install

$ wget https://www.efanomars.com/bins/stmu-20201125-arch-arm64-m.tar.gz
$ sha256sum stmu-20201125-arch-arm64-m.tar.gz    # should return
$ # 55c58c4776209c7364dfd4cca4f9b0f259899aefd94755f6efd7aa4c0939c001
$ tar xvz -f stmu-20201125-arch-arm64-m.tar.gz
$ cd stmu-20201125-arch-arm64
$ ./install-all.sh

Run

$ sonorem
$ pkexec bluetoother # or sudo bluetoother

Uninstall

From the same directory of install-all.sh
$ ./uninstall-all.sh


Debian binary packages (armhf architecture)

For Debian based Linux distros like Raspberry Pi OS, Debian, Ubuntu, etc.

Hardware: Raspberry Pi 3B+

Note: the sudo package must be installed and your user must have permission to execute commands as superuser.

Prerequisite packages

$ sudo apt-get install libgtkmm-3.0-1v5 libbluetooth3 bluez sox espeak policykit-1

Download, unzip and install

$ wget https://www.efanomars.com/bins/stmu-20201125-deb-armhf-d09.tar.gz
$ sha256sum stmu-20201125-deb-armhf-d09.tar.gz    # should return
$ # e67b09f88c2502a87bf8a83d952da96065077f3a01cb30946cb883c730dbd94a
$ tar xvz -f stmu-20201125-deb-armhf-d09.tar.gz
$ cd stmu-20201125-deb-armhf
$ ./install-all.sh

Run

$ sonorem
$ pkexec bluetoother # or sudo bluetoother

Uninstall

From the same directory of install-all.sh
$ ./uninstall-all.sh